Android requires compiler compliance level 5.0 or 6.0. Found ’1.4? instead

Posted in BLOG on January 26th, 2012 by admin

En algunas ocasiones podemos encontrarnos con el siguiente error al momento de desarrollar aplicaciones para Android en nuestro Eclipse:

Android requires compiler compliance level 5.0 or 6.0. Found ’1.4? instead. Please use Android Tools > Fix Project Properties.

Para corregir este problema debemos realizar los siguientes pasos:

      • En eclipse, abrir la ventana de preferencias – Window – Preference
      • En el menú en forma de árbol, en la parte izquierda de la pantalla, hacer clic en Java – Compiler
      • En la opción seleccionada establecer el “Compiler Compliance Level” a 1.6, como muestra la siguiente figura

Eclipse JDK Compliance Option

    • Hacer clic en el link que aparece en la parte superior de la pantalla: Configure Project Specific Settings…, Seleccionar luego el proyecto que estamos trabajando

Eclipse JDK Project Specific Settings

    • En la pantalla que se nos presenta, quitar la selección a la opción: Enable Project Specific Settings

Eclipse JDK Project Specific Settings disabled

  • Aceptar la configuración
  • Eclipse nos indicará que necesitará realizar un Full Build, aceptar esta operación
  • Finalmente, acceder y ejecutar la opción de menú Project – Clean…

En este punto deberíamos tener solucionado nuestro problema.

Comments are closed.